
  VOLUME 05   |    ISSUE 01   

M
A

Y
A

Free W
ith

 D
igit Jan

u
ary  20

10

YOUR HANDY GUIDE TO EVERYDAY TECHNOLOGY

A 9.9 Media Publication

JA
N

U
A

R
Y

 20
10

FA
ST TR

ACK

Maya
To

Getting started

Interface

Modelling

UV Mapping
and texturing

Basic Animation

Dynamics

Lighting

Rendering

Additional Features

Tutorials

Take your first steps into 
the world of 3Dmodeling 
and animation



1

Maya
tot



2FAST TRACK - JANUARY 2010 2

Credits
The People Behind This Book

Editorial
Editor  Robert Sovereign-Smith
Head-Copy Desk Nash David
Writers  Varun Hadkar,
  Tutorials by Prem Moraes, Application Engineer, Autodesk

Design and Layout
Lead Designer Vijay Padaya 
Senior Designer Baiju NV
Cover Design Anil T

© 9.9 Mediaworx Pvt. Ltd.
Published by 9.9 Mediaworx 
No part of this book may be reproduced, stored in a retrieval system or transmitted in any form 
or by any means without the prior written permission of the publisher.

January 2010
Free with Digit. Not to be sold separately. If you have paid separately for this book,
please email the editor at editor@thinkdigit.com along with details of location of
purchase, for appropriate action.



3 FAST TRACK- JANUARY 2010

Chapter 1
GETTING STARTED ......................................................................................................5

Chapter 2
INTERFACE OVERVIEW ...............................................................................................11

Chapter 3
MODELLING ............................................................................................................23

Chapter 4
UV MAPPING AND TEXTURING ..................................................................................29

Chapter 5
BASIC ANIMATION ...................................................................................................37

Chapter 6

DYNAMICS ..............................................................................................................42

Chapter 7
LIGHTING ...............................................................................................................46

Chapter 8
RENDERING.............................................................................................................57

Chapter 9

ADDITIONAL FEATURES .............................................................................................62

Chapter 10
TUTORIALS..............................................................................................................74

Contents



4FAST TRACK - JANUARY 2010

Introduction

Animation is an art that has risen in the last century. 
While art forms such as drawing, sculpting and 
painting allow artists to form shapes that can be 

represented as 2D (two-dimensional) images, animation lets 
you explore a new world. As the saying goes for the people 
working in the animation industry, “We are people who make 
imagination come real”. Through animation, new worlds can 
be imagined. This art form goes through the movement of a 
sequence of drawings or rendered images. In the last couple of 
decades the impact of 3D computer graphics has been immense. 

You’ll find Fast Track to Maya a perfect solution, irrespective 
of whether you're an amateur CG artist or you're just migrating 
from another 3D platform. It introduces you to Maya and shows 
how you can work with Maya to create your art / rendered 
images, whether it's animated or static in design.

This book exposes you to all the facets of Maya, by introducing 
and explaining its tools and functions and help you understand 
how Maya operates. We've included the most interesting 
tutorials within the scope of this Fast Track, so that you can 
have a start without getting bogged down by the immense 
functionality within Autodesk Maya. Working through these 
will give you skills as well as knowledge. These tutorials expose 
you to various ways of accomplishing tasks with this intricate 
and comprehensive artistic tool.

Learning Maya can be overwhelming, but the key is in 
practising and accepting disappointments. Persistence and 
continuous practice will see you through your desired results. 
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A number of people use Maya, including people who want to just know 
about 3D computer graphics (CG), 2D artists who create caricature animation 
for film and television, artists who make high dynamic landscapes and 
those who work on animated short movies. Every CG artist has a basic 
understanding of this software.  

1.1 3D Modelling 
3D modelling is all about creating models of objects or illustrations, which 
can be defined from all angles. The best way to describe this is by modelling 
an object from clay or wood, instead of software used for creating three-
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dimensional shapes or geometry. Just as sculptors use clay to model objects 
in the real world, 3D modelling artists sculpt the object in a virtual 3D 
application such as Maya.
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There are three types of surfaces that an artist uses for modelling. They 
are polygon surfaces, NURBS and subdivision surfaces. 

Polygon
Polygon modelling can be best described as a mesh created with a number 
of flat surfaces. The mesh can be modified (the surfaces can be added or 
subtracted) according to the results you want to achieve.

NURBS
A NURBS surface is made up of intersecting curves – these are less flexible 
when an artist needs to create a complex geometrical object. 

Subdivision
Subdivision modelling entails the qualities of both of polygon and NURBS 
surfaces. This type of modelling is used to make the most complex part of the 
geometry or model that you want to create – such as a ear and nose. 

1.2 Animation 
This is a way of adding some life or action to an object that would otherwise 
be static. 

Animation not only represents character animation, it also means that 
you can form, deform, change and metamorphose objects. Animation also 
helps to give your character expressions and emotions. 
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According to Walt Disney, “Animation offers a medium of story telling 
and visual entertainment which can bring pleasure and information to 
people of all ages everywhere in the world.”  

1.3 Dynamics 
Wind, water, fire, smoke and any other natural phenomenon falls under 

Image courtesy of Industrial Light & Magic
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this category. Anything that has something to do with these and physics 
simulations is categorised as effects. As a general term, effects animation 
differs from animation. Natural effects which cannot be produced by the 
means of a key frame (animating frame by frame) animation are created 
by effects. 

Follow the instructions below to make a decent beginner’s scene. This 
will give you an overall understanding of how Maya works. Later, you can 
add your own effects, simulations, lighting effects, animations and models 
and create your own scene. This software has the same look and feel in all 
operating systems (Windows, OS X).



Maya

Interface overview
A piece of software with so many buttons and icons spread all over the 
window can be quite a pain. But once you start exploring it, you will find 
all those buttons in the Maya interface useful. To help you understand this 
software, we will try and keep it simple and straightforward and explain all 
computer graphics jargon that we come across.

2.1 Basic Tools, Menus, Windows and Editors
When you first start Maya, you'll see the perspective view. In the vertical 
rectangular white area on the right hand side, you have the ‘Channels View’ 
and below that, you have ‘Layers’. 
Menubox
When you click on this, a drop down box will appear, from where you can 
choose the various modes in Maya.

2
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For example, if you need to create an animation, or need to use a skeleton, 
choose Animation from the drop down menu. If it has something to do with fire, 

The Maya interface is your playground

Spend some time getting familiar with the Maya interface
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wind or clouds then use the 
Dynamics option. Once an 
option is selected, the menu 
bar modifies itself in such a 
way that all the tools related 
to that category are lined up 
for the artist.

Shelf
This is where all the 
shortcuts of the tools are 
placed, regardless of the 
menu. Each tab you click 
opens up a set of tools. 
90 per cent of the tools in 
Maya are located in the 
shelf, unless you install 
third-party plug-ins or 
scripts, or make your own custom shelves.

Channel Box Editor
In this box editor, when you select the object that you create, it gives you 
a numerical value of how big the object is according to width, height, 
radius, and also the translation coordinates for where your object lays in 
the 3D space.

Layers
Layers separate one object from another. This is again defined by you. You 
can set as many objects as you wish to be in one single layer. This is an 
important feature when you are finishing up your scene and getting ready 
to render it.

Toolbox
This is where you find the physical controls of the object. In Maya, if 

Select your mode from the drop down box

You’ll fi nd most tools in the shelf
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you hover over any 
icon you can see a 
description of that 
tool at the bottom of 
the page. 

Bounding box 
Selection tool is used 
to select objects, 
faces, verticles, edges 
and UVs. 

Selection tool 
or the lasso tool is 
used when there are 
complex models and 
you need a curved 
selection instead of 
a box. 

Paint Selection 
Tool is used to select 
vertices in a complex 
mesh smoothly. 
Wherever you move 
your brush, you can 
select vertices.
•  The Move, Rotate 

and Scale tools: 
these are widely used in Maya for just about everything. They’re used to 
move, rotate and scale objects respectively.

•  Universal Manipulator: This has the function of move, rotate and scale in 
one feature. Can be handy sometimes.

•  Soft Modification tool: A soft modifying tool is used to deform vertices 
smoothly in an object.

•  Show Manipulator: This is used if there is a manipulator attached to a node.
•  Polygon Cylinder tool: This is used to make a polygonal cylinder, as the 

name suggests. 

Shortcuts 
These are effective when an object is selected. Make sure you have turned 

If you’re not sure what a particular tool is, just hover over its icon and read the 
description at the bottom of the page
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off Caps Lock.
[W]: to move the object in X,Y or Z axis 
[E]: to rotate the object on any axis
[R]: to scale the selected objects 

Screen Setup
This is fairly simple to understand. You can click on any 
of the buttons and then see how the layout changes. This 
allows you to adjust the display according to your wishes.

Animation Timeline
Just as with any other timeline, this shows you which 
frame you are on.

Range Slider
This is simply a slider used to isolate the frames on which 
an artist wishes to work.

Mel/Python script editor
This is where you input commands and execute your 
scripts. The icon on the extreme right of the same line is 
used to expand the editor and typing area, so that you can 
see more than a single line of script. 

The Attribute Editor
This lists the attributes of the selected object and is a 
larger version of the Channel Box. The Channel Box 
shows you the compact version of the object’s attributes, 
whereas the attribute editor gives you full control of each 
and every attribute of the object. Each tab on the attribute 
editor represents a set of information for the selected 
object. This is arguably the most important tool in Maya.

You can activate the Attribute editor by clicking on 
the red coloured area. You can also select the object and 
click [Ctrl] + [A] on both Windows and Mac to activate this. The section 
marked in Red is the Attribute editor. All the shortcuts for the Windows, 
Linux and Mac OS X version are the same.

This is fairly simple to 
understand. You can click 
on any of the buttons and 
then see how the layout 
changes. This allows you 
to adjust the display 
according to your wishes
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Outliner
The Outliner 
is a window 
where all the 
objects and 
attributes in 
your scene 
are compiled. 
You can hide 
objects by 
selecting them 
and pressing 
[Ctrl] + [H] 
and unhide 
them by going to Windows > Outliner, selecting the object and pressing 
[Shift] + [H]. 

If you need to replicate, why rework? Use scripting

Hide/Unhide is as simple as [Ctrl] + [H] and [Shift] + [H] 
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The Status Line
You won’t be using this a great deal 
in the scene that we are going to 
work on, apart from the first four 
and the last four buttons. These 
are: Menu select, New scene, Open 
scene, Save scene, and, Render, IPR 
render, Render globals and text-
based selection. There is another set 
of buttons in each viewport.

Here is a short explanation of 
these buttons, from left to right:
•  This is used to select a camera. 

If you are viewing a scene, which 
has at least 10-20 cameras, and 
Camera 1 is your viewing camera, if 
you click this button, your viewing 
camera will be selected.

•  This also selects the camera 
attributes. Every object has 
attributes. If you need to change the 
focal length or the resolution, this is 
the button you would use.

• To put bookmarks on the camera.
• To add an image plane.
• To toggle the grid ON and OFF.
• To add a film gate.
• To add a resolution gate.
• Adding a mask to the gates.
•  Switch the field chart ON and 

OFF (field chart represents the 12 
standard field animation cell sizes).

•  Switch Safe action ON and OFF 
(This is a viewing box where 
you should keep all your actions 
and animation sequences inside 
this area, if you are working on a 
production). ViewportBarStatusLine
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• Toggle safe titles ON and OFF (this box defines the region where the Titles 
/ Subtitles can be added to your scene).
• Object Wireframe mode ([3])
• Object shaded mode ([4])
• Object wireframe and shaded mode. ( [5])
• Object textured mode ([6])
• Using all lights
• Using shadows
• High Quality 
• Isolate selected objects
• X-ray 
• X-ray active components
• X-ray joints

File Menu
Open Scene: Open an existing scene on your computer and/or an external 
drive. You can also press [Ctrl] + [O].

Save Scene: Save the current scene. Alternatively, press [Ctrl] + [S].
Save Scene As: Save your file in Maya ASCII or Maya BINARY file format. 
Maya ASCII is an editable file format, which can be opened in various 
versions of Maya. It has a much larger file size, whereas Maya BINARY is 
compacted and is unusable with other versions of Autodesk Maya.

Import: Useful for importing other scenes or objects that can be read by 
Maya. Use the keyboard shortcut [Ctrl] + [I].

Export All: Exports all the objects in the current scene in user specified 
formats for access by other applications.

Export Selection: Similar to export all, except that it exports the selected 
object(s).

Window Menu
This is one of the most important menus, and consists of:
• General Editors
• Rendering Editors
• Hypershade
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• Animation Editors
• Relationship Editors
• Attribute Editor
• Outliner
• UV Texture Editor
• Playblast

The Hotbox
If you hold down the space bar, you will see a cluster of menus that pop 
up on your screen, centred around the cursor. This pop-up menu is called 
the Hotbox. You can change and customise the hotbox by holding down 
the space bar and left mouse button. Any viewport can be changed into 

Even creating 3D objects are as simple as drag and drop
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any of the orthographic views 
or perspective views if you hold 
down space bar and right-click. 

While still holding the right 
mouse button down (a smaller 
marking menu will appear), 
drag your mouse to the option 
you want to enable or disable). 
For example, to show all the 
menus in the hotbox, hold down 
the Space bar and right-click 
on the “Maya” and drag to 
“hotbox styles”.

2.2 Navigation and 
creating an object

2.2.1 Navigation
To navigate in Maya, you need 
a three-button mouse. With 
[Alt] pressed, pressing the 
left button of the mouse in the 
perspective view panel will 
tumble your view. Similarly, 
holding down the [Alt] key and pressing the middle mouse button in the 
view panel will track or pan your view. On the other hand, holding down the 
[Alt] key and pressing the right mouse button in the view panel will dolly 
your view. The track and dolly moves also work in most Maya windows, 
such as the Hypergraph (an area where all the nodes which are in the scene 
are displayed), not just in the view panels.

[Alt] + right-click and drag mouse (up and down or sideways) in a 
viewport to zoom in and out.  Scrolling the wheel (if you have a wheel mouse) 
zooms in and out. [Alt] + left-click and drag mouse around the 
viewport to rotate it. [Alt] + Middle mouse button to Pan inside the viewport.

2.2.2 Creating an object for navigation purpose
Select Polygons from the Menu box and go to Create > Polygon 
Primitive > Sphere. You can always pick other shapes such as a 

You can edit components of your object by going to the 
channel box 
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cylinder, cube or pyramid. Next, drag anywhere in the viewport, to create a 
sphere in 3D space. 

Once you have created a sphere, you can then look on the right side at the 
Channels Box – this will no longer be blank. The new values it contains are 
related to the selected object, which in this case is the sphere.

After creating the sphere, hit the hot key [W] on your keyboard and you’ll 
see a tool that’s pointing in various directions. Try left-clicking one of the 
three arrows and move it around. You’ll notice that the object moves, and the 
translate x, y and z values in the Channel Box change. The translation values 
tell you where the object sits in Maya’s 3D space. Now try hitting [E] – this 
will display four rings around the object which are basically for x, y and z 
rotation. Similarly, when you press [R], you can scale the object accordingly. 

Now that you have created an object and are familiar with the Channel 
Box, let’s see how to change the segments of the shape. 

In the Channel Box, under the values for Translate, Rotation, Scale and 
Visibility, you’ll see a section called SHAPES with a subsection called 
INPUTS. Here, you will find polySphere1. Click on this to see how the 
selected mesh or geometry has been created.

In this example, it’s a polygon sphere and there are no other polygon 
spheres in the scene, hence the name polySphere1. If you click on a value 
such as Radius, it becomes editable so that you can change the size of the 
radius according to your needs. The Subdivision Axis and Height are the 
curves that you see around the geometry. If you change any of these values, 
you will see these changes reflected in the mesh. 

Hotkeys: There are a number of hotkeys in Maya and you can further 
customise the list. The basic ones are:

Common Hotkeys used in Maya:
[F1] Maya Help 
[F2] Animation menu 
[F3] Modelling menu 
[F4] Surfaces menu 
[1] Rough NURBS smooth/Actual polygonal preview 
[2] Medium NURBS smooth/Polygonal smooth mesh display 
[3] Fine NURBS smooth/Polygonal smooth preview 
[4] Wireframe mode 
[5] Shaded mode 
[6] Hardware texturing 
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[7] Show light simulation 
[Q] Select tool 
[W] Move tool 
[E] Rotate tool 
[R] Scale tool 
[T] Show manipulators 
[Y] Last tool selected 
[S] Sets a keyframe 
[F] Frame selection in current view 
[G] Repeat last command 
[Ctrl] + [G] Groups selection 
[P] Parents first selection (or more) to last selected 
[Shift] + [P] Unparents first selection (or more) to last selected 
[V] Snap to point 
[B] Resizes artisan brush 
[X] Snap to grid 
[Ctrl] + [Z] Undo 
[Shift] + [Z] Redo 
[+] Increase manipulator size 
[-] Decrease manipulator size 
Hold Spacebar to show hotbox 

Now that you have seen what the basic display of Maya looks like, let’s 
jump inside and have a look at the contents of the most frequently used 
menus that will be handy for a basic work flow. 
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Modelling 
Before we can start modelling, we need to set the project in order to save our 
scene files in a single location. To do this, go to File > Project > New.

You can set any 
name for the project. 
For now we'll name 
it Cube_House. Make 
sure you create an 
empty folder on your 
hard drive and browse 
to that folder. Click 
on Use Defaults 
(at the bottom of the 
dialogue box), which 
will fill up all the 
boxes with particular 
names and then 
press Accept. This 
will create a number 
of folders in the 
folder that you have Fill the relevant information to organise your work

3

Maya
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selected as the location for 
your project. After creating 
a project, you can save a 
file by giving it the name 
CubeHouse, or anything 
suitable, and it will be saved 
into the scenes folder of the 
same location. 

3.1 Polygon Modelling 
Let’s start off with a cube 
this time. Go to Create > 
Polygons Primitive > 
Cube, then drag and click 
twice in the viewport to create 
the object. Just to have a better 
look from all directions, we 
shall rotate the viewport and 
even zoom in to some sections – this is something you will need to do quite 
often, in order to understand what your object looks like from all directions. 

Start by dividing the cube into 3 parts

M
M
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Pointer – If you zoom out too much, to the extent that the object 
isn’t visible, then you can simply select the object from the Outliner and 
press [F].

We are now going to populate this scene with some more cubes. You can 
either duplicate the boxes or cubes that you have by pressing [Ctrl] + [D] 
and placing it wherever you want, or you can create new ones by the same 
method as before. Once you’ve placed the cubes, you need to put them in a 
room, which we now need to create. We can do this by creating a cube much 
bigger than the rest of the cubes, maybe twenty times larger than the others 
and place them on the floor - if you duplicate and scale the existing cubes, 
they will lose contact with the ground and will then be floating over it. To 
do this, you need to check all four viewports and see if everything aligns 
properly. Remember to check your scene in the perspective view by rotating, 
zooming and panning all the time. Since we are covering the modelling 
section and it’s a cube house, let’s just model a chair.

Start off by creating a rectangular box by using the polygon cube tool. 
Select the object and press [Ctrl] + [A] to switch to the Channel Box. In 
Shapes > Polycube, increase the subdivisions height to 3.

You’ll see that the cube has now been divided into three parts. Hold the 
right-click on the selected object, you’ll see options including Edge, Vertex, 
Faces, Object Mode, UV, Vertex Face and Multi. Make sure you’re in the 
wireframe mode by pressing [4]. Hold the right-click on the object and 
select EDGE. This will change the object’s mode and also the colour of the 
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wires to EDGE selection where you can select any line that you see on the 
mesh. Vertex mode is used when you need to modify the dark pink points 
that you see in the 3D space. When you click or select them they turn yellow, 
which indicates that they’re selected. Face mode is used when you need 
to play around with the faces of a mesh. These are the three main things 
that you need most of the time when you are modelling. Let’s now move 
on to the modelling. Once you have made the cube and divided it into three 
parts, select the vertices and the objects. For an in-depth tutorial, follow the 
instructions on the video titled Basic Modelling from our DVD.

Create a new scene in a new project. Point to the location where you want 
your scene to be saved along with the associated files. Next, save the file in 
the scene’s directory and create a box by using the extrude method to make 
the walls thicker (this is optional, you can either make them thinner or leave 
it as it is). You can use extrude only with faces without any other mode. It 
takes four cubes to create the windows for the walls. Next, let some sunlight 
through the windows. Once they’re placed appropriately, delete the history 
by going to Edit > Delete by Type > History – this ensures the 
objects carry no history.

Click on the huge box, (the walls), and press Shift + Left Click on one 
of the boxes; then go to Edit Mesh > Boolean > Difference (make 
sure you have chosen Polygons from the drop down menubox else this 
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menu won’t show up). You will now see a single window in the wall. You 
can repeat these steps for the rest of the boxes using the same method four 
times. Or, you can simply click on the walls, then press Shift + left-click 
the boxes, and press [G]. This will repeat the last function used (which was 
Edit Mesh > Boolean > Difference). You can do this for all four of 
the objects and you have windows on the wall.

3.2 NURBS modelling
All the modelling that we have done up to now has been using polygons. We 
shall now use NURBS. We will stick to the basic shapes and animation once 
we are done with the UVMapping and texturing. Always remember you 
cannot UVMap a NURBS surface, because NURBS are curves. You need to 
convert the mesh into polygons and then map it. Click in the blank space in 
the viewport and press [F] to centre your whole scene in the viewport.

Now that you have understood Polygons and NURBS modelling, let’s set 
up our camera from where we will be rendering our final scene. There are 
three types of cameras in Maya.

Camera
You can have free movements, Check Create > Cameras > Camera to 
set its options.
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Camera and Aim
Is used when you need a certain point as the center of the camera all the time. 
Check Create > Cameras > Camera and Aim to set its options.

Camera, Aim and Up
This one is to specify which end of the camera must face upward. This 
camera is best for complex animations, such as a camera that travels along a 

looping roller coaster. Check Create > Cameras > Camera, Aim, and 
Up to set its options.

Once you create the free hold camera, select the camera and go to  
Viewport Panel > Look through Selected. By clicking this, you will 
be able to see through the camera. Set where you want your camera to be by 
zooming out, rotating and panning, and put it in a position. You can change 
the camera attributes if you want, by clicking the camera and pressing 
[Ctrl] + [A], which will open the attribute editor. You can play around 
with it by changing the values in CameraShape1, 2 or whichever number 
your camera shows. For a more practical approach, watch the tutorial videos 
on this month's DVD.

You can put as many objects as you want in that box since we will be 
lighting the scene accordingly, rendering it and compositing it finally. Ok, 
let’s take a step ahead by UVMapping our objects and then finding suitable 
textures for them. 

M
M
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UVMapping and Texturing

This step is followed every time a mesh is created and needs a texture 
wrapped onto it like an overcoat. It’s called UVMapping because it takes the 
U and V coordinates of the mesh and drops it on a flat surface where the user 
can easily put the texture on it. There are five main types of UV mapping in 
Maya, namely, Automatic Mapping, Spherical, Cylindrical and Planer.

4

Maya
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4.1 Finding the Perfect look for an object

Automatic Mapping
This kind of mapping works well with any kind of objects. Surfaces, 
Cylinders, Spheres. When you click on this option where the amount of 
projections you need to put on the object, Maya automatically puts that 
number of projection around it and places it on a flat surface. Remember this 
can be the best or could be the worst for certain objects. If certain parts are 
away from the projection it will give you absurd shapes, which you need to 
stitch together. 

Spherical Mapping
This is used when there is a spherical shape on an object or when there are 
spheres included in the scene. It becomes easier if you use this mapping 
where you can see a curvature in an object.

Cylindrical Mapping
Comes in handy when you need to put textures on something that looks 
cylindrical, like a pipe or poles or anything that is elongated.

Planer Mapping
It’s used mainly when there is a flat surface. This works perfectly well on a 
surface like that. 

Identify the shape of the object that you will be UV mapping. Rotate 
it in 360 degrees and see which of the above mapping processes fits in 
appropriately. 

One can access the UV texture editor as we call it from Windows > UV 
Texture Editor where you can modify your map so that your texture will 
look much more accurate. 

Before you can start your UV map, change your interface to something 
that suits this technique. In your Screen Setup toolbox, click on the fifth 
icon that says Hypershade / Perspective. Hover your mouse over it, to see 
the name and then click it. You will see the layout changing, on your left 
hand side is the Hypershade where all the colours, materials and textures 
go and on your right is the perspective view. Click on the Panels dropdown 
in the Hypershade window and select Panels > Panel > UV Texture 
Editor. This will bring the UV Texture Editor in front. If you press [F] in 
the window you’ll fit the whole view inside. 
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Remember to keep saving your work. 
Now, Open your Cube_House scene and 
select one of the small cubes. Since it’s a 
cube and not a sphere or a cylinder or even a 
flat planer, you can do Automatic Mapping 
on it. Click Create UVs > Automatic 
Mapping. This will put six small colourful 
and transparent projections around the 
object. You can change the number from 
6 to 8 or 12 by clicking on the small square box beside your Automatic 
Mapping in Create UVs > Automatic Mapping (Small square option 
box). Once you map it, check the UV texture editor. You'll find that the 
mapping and sizes have changed and this is where you’ll see the UVs laid 
out on a grid surface. To learn how you can stitch everything together and 
make it ready for texturing, watch the video titled Uvmap_Box on our DVD. 

In the video, you'll learn how to:
•  Split the window between UV Texture Editor and the Perspective Viewport.
•  See the Shaded View by clicking on the blue box icon.
• After selecting the box, go to the Attribute Editor and click on the
•  PolySurfaceShape1 tab and tick the Opposite checkbox. You can now see the 

difference in the viewport.
Save the file as UVmap_box and press [Enter]. This saves in the scene 

folder where you had set your project in. Select any box; hold the right-
click, which will show you a drop down menu as well. Go to Assign New 
Material > Lambert (We are only putting a texture on Out box to check 
that our UV Mapping happens accurately) and rename it to Box_texture. 
Click on the small black and white checker box next to colour and select File 
from the window.

Zoom into the box and you can see that the image is wrapped around 
it. Select the box again and go in the Box_Texture tab in the Attribute 
Editor and click on the small arrow beside colour which previously was 
a small checker. Once you go inside, you’ll notice two tabs File and 
Place2dTexture1. Click on Place2dTexture1, locate Repeat UV and 
enter a value of 5 or 6 in the box and press [Enter]. You will now see that 
the squares on the boxes have gone smaller. The math is that the texture has 
only repeated itself five times, which is why it goes smaller. 

In the UV Texture editor, expand the Viewport by hovering your mouse 

The main aim to use this kind of texture 
is to check if your UV mapping is correct. 
You will notice that if any of the squares 
are stretched or squashed or don’t look 
like squares any more, it only means that 
your mapping has gone wrong somewhere 
and you need to edit it again. If you have 
all squares with same width and height 
all over the model, then it’s a very good 
UV mapping.

Note
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on it and then lightly pressing the spacebar. Click on the Move UV Shell 
Tool and move the layout aside so that we can view it properly without any 
bright colours from the image. 

Staying on Polygons mode, click Create UVs > Automatic Mapping. 
You will now see six projections on all sides of the box.

Go to the object mode by keeping your right-mouse button pressed and 
selecting it. Take the Move UV Shell Tool and again move it on the grey area 
to view it properly. 

Press [W] to come out of the tool and then keep your right-click pressed 
and select Edge.

Select an Edge, (when you do that you will see another edge being selected. 
This is because when you UV map your object, it splits the edges into two or 
more parts) and click on the Move and sew the selected edges button. 
This will stitch the two parts together. We do the same to the rest of the edges. 
You need to look at the model and see which edge you are selecting; else your 
whole map will turn out to be a small dot.

Once you sew all the edges together, rotate your UV and place it back in 
the texture. You can then have a look at your box where all the squares have 
the similar width and height.

You can use this method to UV map all the objects in your scene, 
including the walls. 

4.2 Texturing
The Hypershade is the central working area of Maya rendering, where 
you can build shading networks by creating, editing, and connecting 
rendering nodes such as textures, materials, lights, rendering utilities and 
special effects.

In this method, the user starts giving the look of the object by giving it a 
skin. You can find innumerable images or textures online, and many artists 
go to http://www.cgtextures.com.

This method comes right after UV Mapping, because if you don’t map 
your U & V coordinates and if you apply your textures on to it, they will 
look really weird and unplaced which you wouldn’t want. Also keeping in 
mind that the textures you choose should go with the scene and should look 
half retro, partly modern, partly futuristic unless that is what you were 
intending to get. 

Most texturing is done from a window called Hypershade, which can be 
found in Windows > Rendering Editors > Hypershade.
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Hypershade

Maya’s Hypershade is one place where you need to spend considerable 
amount of time to understand it and master it since it provides an easy way 
to create, edit, and connect rendering nodes such as textures, materials, 
lights, rendering utilities, and special effects. 

For a detailed look at Hypershade and it functionality, watch the video 
titled Hypershade_Overview on this month's DVD. 

Open the last UV mapping file and save it as Hypershade_Overview.ma. 
You can click on the fifth button of the screen set-up to activate Hypershade 
or you can simply go to Windows > Rendering Editors > Hypershade. 
On the left side you see a Create bar. This is the bar where all the materials 
lay. You can read the material types as well. On the right-side of the window 
is the Top and Bottom tabs. The Top tabs, give you information of materials, 
lights, camera and effects in the scene. Similarly, the Bottom tab is the work 
area where you drag your nodes, do your mathematical calculations to create 

Spend time to understand the detailed menu of Hypershade
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a shader and access the deep values/nodes that are stored in the shading 
network. The bar on the top of Hypershade is the Menu bar. In the Materials 
tab, click on the first shader that you see. Instantly, the attribute editor points 
out the attributes of the shader. Hold the right-button of the mouse on the 
object and check Select Object with Materials. This will show you 
which 3D objects are using that material. You can try it out with the rest of 
the shaders as well.

Try and click on every button on top and see how it changes the view 
within the Hypershade tool. If you have several unnecessary shaders in your 
scene, go to Edit > Delete unused Nodes which will clear out the scene. 
We shall now see the basics of what each and every material that you see in 
the create bar does.

Surface Materials
This type of material follows the types of surfaces onto which you can map 
textures. Properties or attributes such as shine, matte, reflectivity and gloss, 
vary among the different types of materials in Maya. For 
example, if the texture requires a shiny surface, such 
as chrome, use a Phong or a Blinn material rather than 
something like a Lambert.

Volumetric Materials
This is nothing but a physical appearance of atmosphere 
like fog or air in space, which is also surrounded with 
other objects.

Displacement Materials
The Displacement lets the user emboss or carve bumps 
or dents into the surface by assigning images or colours 
to it.

2D Textures
This kind of material wraps around an object like 
a wallpaper.

3D Textures
A 3D texture projects itself through a surface, like wood 
or the texture on the marbles. 2D Textures
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Env Textures
A set of materials used to create physical sun and sky.

General Utilities
A set of nodes used to do math operations in the Hypershade.

Colour Utilities
A set of nodes to manipulate the color in the Hypershade. Now that you have 
a file (Cubehouse_UVMap.ma), which has the objects that are UVmapped, 
let’s start with the texturing. We will be using the word ‘shader’ often. A 
shader is nothing but a material used to colour or skin a 3D object. For this 
you would need an image editing software, preferably Photoshop.

From where we last left the scene, follow these steps:
•  Save the file as CubeHouse_Texturing.ma. 
•  Remove the UV colorful map from all the objects by clicking on the object 

and going in their attributes, click on the Box_Texture tab (The place 
where we assigned the UV.jpg image previously), right-click on colour 
and then click on Break Connection. This will delete the image that was 
connected to the shader. 

•  Drag the Colour bar to increase or decrease the intensity. This will give you 
an understanding that the particular shader is affecting those objects.

•  Once that is done, in the UV Texture Editor Viewport, go to Image > 
Create PSD Network. This will create a shading network where you can 
define what image you want to put on the UV map and how you want the 
3D object to look.

•  After clicking the Create PSD Network option a small window will pop-up, 
this is where you need to specify:

a. Where would you like to save the PSD network file. 
b. What resolution is your image supposed to be and 
c.  What all do you need in your shader, eg. colour, bump, diffuse and 

transparency. 
For this example, we shall choose colour and bump. Colour is where 

the proper image goes and bump is where the black and white image that 
calculates how much bump or roughness an object should have. Click on 
create. Maya calculates all the attributes and finally gives out a path where 
your image has been saved as a PSD file.
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Save the fi le
Open the PSD file in Photoshop. You will notice the same UV layout in the 
PSD file. Import or copy the file CardboardBox0017_S.jpg from the PSD file.

Place the image in such a way that it covers up the whole layout. Now 
import the Recycle.jpg image and place somewhere over the cardboard, but 
inside the layout.

Merge the two layers and drag the layer inside the Box_Texture.color 
folder. Duplicate the image and drag the new copy under Box_Texture.bump 
folder. Delete the UVSnapShot along with Layer one and Layer two.

Select the layer which is under Box_texture.bump and desaturate it 
completely. Save the file and you can apply the same procedure to the walls, 
tables and chair.

Open Maya and select the boxes that the shader was assigned to. Go to the 
Textured view by pressing [6], you will see that the texture has been loaded 
and the boxes now look like they are supposed to.

Now that you have an understanding of how you can assign and create a 
texture for an object, you can do it for the rest of the objects. For now, we'll 
assign a simple colour to the rest of the objects in the scene.

To do this, hold the right mouse button and go to Assign New Shader 
> Lambert. Rename the shader to avoid confusion.

Click on the small grey rectangle beside Color and change it to bright red.
Do the same for the rest of the boxes and chairs. We are going to keep it short 
and simple for the walls. Either apply a colour to it or the plaster texture in 
your source images folder. 
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Most animation instructors start off with the age-old bouncing ball animation 
exercise. It has to move, rotate and deform in a convincing manner. To 
reach our production goals, we need to follow certain guidelines and 
practices. Typically, Maya doesn’t show all of this in an obvious way for a 
user to animate, but we can now decode it step-by-step and jump into the 
animation boots. 

Start off by setting your animation preferences by going to Windows > 
Setting and Preferences > Preferences. You will see a new window 
pop-up. Navigate to Settings in the Categories section. The two main 
things in this window are the Working Units (the type of  measurements you 
like to work on, the default is centimetres) and the Time (i.e. what frame rate 
you want). Let's apply a ramp shader to the ball, so we know which direction 

5
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it is rotating in. Since we already have our camera set, go to Viewport > 
panel > Perspective > Camera1. Now save your scene.

Let's start by figuring how the path of the ball is going to be relative to 
the camera so that we know when it enters the frame and when it exits. We 
shall start by having the ball coming from the window, bouncing around and 
finally hitting the camera. Move the ball around in front of the camera to 
get an idea how you would like it to move. Press [S] to set keyframe on the 
frame that you want to animate. However, if you do that then all values will 

be animated, including translation, rotation and scale. Select the ball and 
place it outside the window and rotate it to show that it is coming inside the 
house naturally or rather someone threw it. Clear all transformations on the 
ball by going to Modify > Freeze Transformation. 

Animating
Increase the time slider by entering a number somewhere around 44 instead 
of say 24 on the timeline. Since our ball is going to bounce in the scene. Go in 
the channel box and lock the X, Y and Z scale for the NURBS sphere or the 
ball for now, just so we won't have any scaling problems later. Now, select 
the balls and press [S] while you are on the first frame (this will put a key 
frame on that particular frame i.e. all the values on that frame remain static. 

Change the look of your graph editor’s Translate Y curve to something like this
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Go to another frame, say frame 12 and move the ball on or near the ground 
and set another key frame. What we are doing here is setting up where the 
ball is going to hit and bounce. Scrub through the time-line to see the ball 
movements. Once you’re satisfied with that, go to another frame and move 
the ball up in the air again to follow the motion and press [S]. Follow these 
steps until you are satisfied with the bouncing look. Now that we have set-
up the ball animation, refine it by going to Graph Editor  located under 
Windows > Animation Editor > Graph Editor. 

The Graph Editor contains tools and operations for manipulating 
animation curves and keys within the graph view of the Graph Editor.

When you select an object, you will see your object NURBSSphere1 on the 
left side of the editor, along with the animated values of the Translation and 
Rotation of the X, Y and Z curve. Select Translate Y from the left-hand side 
and you will see only that line or curve. When you select the curve, it will 
turn white (the default curve selection colour). Now try and select a single 
point, you will see a tangent connected to it. Select one of the two handles. 
Notice that the handle that is selected turns yellow. If you move the handle, 
you are also changing the animation values. Keep the Graph Editor open on 
one side and view the ball in one of the viewports.

You will need to select the points, break the tangents and manipulate 
it accordingly. Follow the videos titled AnimationPart1 and 2 on this 
month's DVD. 

Once you are done with the graph editor, save 
your file and view the animation. Next, add an 
animated feel to the ball by adding some rotation 
and squash effect. 

Rotation and squash
Since the ball looks static when it’s bouncing, let’s 
give an exaggerated feel to it. The best way to 
animate is always via the graph editor. Always 
play your animation to get an idea how it looking 
and what kind of movements would make it 
look better. 

To rotate the ball, go to the frame where the ball 
is bouncing on the ground, in our case it's frame 12, 
zoom in and press [E] or select the rotate tool. Rotate it ever so slightly to get 
the movement right. Look at references of a bouncing ball to get the desired 
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look for it). Set a key by pressing [S] on that frame. Now go on the other 
keyed frame, which is frame 24 and rotate it again. Press [S] when you’re 
satisfied with it. Do the same kind of rotation on every frame where you see 
the key, keeping in mind that the rotation should be subtle and in the flow. 
Any absurd rotation can make it look really weird. 

Once you are through with the rotation animation, view it by clicking the 
play button. To start off with the stretch and squash effect, go to the frame 
where you see the ball lands on the ground, the same frame where we set our 
keyframe. Left-click and select the ball. Next select animation from the Menu 
box. In the create deformers dropdown, go to Nonlinear > Squash. This 
will add a deformer to the ball. A deformer is nothing but a set of attributes 
that change the formation of the ball and gives you complete control to 
manipulate its shape. You will see a thin line in the middle of the balls. 

You will see that it has a few options inside, for this illustration we will be 
using Factor and Max Expand Position. 

Factor
Specifies the amount of squashing or 
stretching. Increasing negative values 
specify squashing along deformer’s 
local Y-axis. Increasing positive values 
specify stretching along deformer’s local 
Y-axis. Use the slider to select values from 
-10.0000 to 10.0000. Default is 0.0000 
(no squashing or stretching).

Max Expand Position
Specifies the centre of maximum 
expansion between the high bound 
position and the low bound position. 
Values can be between 0.01000 (near the 
low bound position) and 0.9900 (near 
the high bound position). Use the slider 
to select values from 0.0100 to 0.9900. 
Default value is 0.5000. Before you can 
change any of the values, you need to 
position your deformer in a straight line if 
it is facing horizontally or diagonally. 

Keeping the line selected, go to the channels 
box and locate something squash1 and click 
on it
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Change the value of coordinates to 0 (Zero). This will get the deformer 
facing in the correct direction. While the deformer is selected, go to the 
channel box and change the factor value to 0.4 or even -0.4. You can see 
how the ball is squashing and stretching. If you scrub through the timeline, 
you will notice that the deformer stays in its place and if you change the fact 
value, the ball doesn’t deform that well or in some cases it doesn’t deform at 
all. This is when the term “parenting” comes in to picture. 

Parenting means when two objects are parented together, it will make 
a parent and child relationship between the two. In other words, the child 
object will follow the parent. If two objects are selected in sequence, the first 
selected object becomes a child of the second selected object. In this case we 
need to select the line (deformer) first and then the ball. Select the line. Press 
Shift + left mouse button and click on the ball. Now go to Edit > Parent. 
This will parent them together.

Once you are done with parenting, start deforming the ball. When the ball 
comes from outside the window and hits the ground, it should squash a little. 
So, select the deformer and go to Factor. Change the values where it looks 
like it’s squashed and right-click on the value and select Key Selected 
from the menu. Go back to the first frame and change the factor’s value to 
0 and do the same, right-click and set a key there. 

Playback frames 1 to 12 and notice how the shape deforms itself. Scrub 
through it and where you see the ball isn’t deforming well, you can change 
the factor rate and set a key there. You can put set any number of keys as 
long as it looks good and does not jitter. Repeat the same steps for the rest of 
the frames to get the result you want. You can also play with Max Expand 
Position so as to put minor details where necessary. 
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Dynamics (Adding fi re and smoke)
Dynamics, as the name suggests refers to the physics of stimulating 
development and forces of natural phenomena. This technique is used 
in Maya to create effects like Fire, smoke, Earthquakes, glass shatter or 
anything that has to do with nature and its forces. To access dynamics select 
Dynamics from the Menubox dropdown.

6
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6.1 Using the elements from the default Library
By default, Maya has a number of effects in its library called Visor. To access 
Visor, go to Window > General Editors > Visor.

This window will show you a number of folders, with different Effects 
and Mesh. For now, since we are focusing on the fire and smoke effects, lets 
add them then in an empty Maya scene. To add fire, do the following:
�  Start a new scene.
�  Open Visor and Locate the Tab called Fluid Examples. 
�  Select the folder called “Fire” (This is where you will see a bunch of fire 

effects).
�  Select the Flame.ma icon with your middle-mouse button and drag and 

drop it in your scene. 
�  Extend the frame range to 100 let the frame buffer for few frames.
�  Play the animation and Render a single frame by clicking the Render the 

current frame icon. This is how you can get fire, which is in the Maya 
library. Similarly, to create smoke, go to Visor > Fluid Examples > 
Smoke and select the smoke you like. Drag and drop it in the scene, play it 
and check the single frame render. For a better understanding on smoke 
and fire, watch the video titled Dynamics_visor in this month's DVD. 

6.2 Creating a custom dynamic element (Fire)
To create custom Fire using Maya, start with an empty scene. Make sure the 
Dynamics menu in the menubox is active, and then go to Fluid Effects > 
Create 3D Container with Emitter. Select the Emitter (which looks 
like a small circle inside the container that was just created) and move it closer 

Click on it and you will get another bunch of folders on your left side
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to the Grid of the container. Make sure 
you don’t take the emitter outside the 
container. Increase the timeline to 200 
frames. Select the container you just 
created, and then go to its attributes 
(make sure you are looking at the 
fluidShape1 attributes).

For now, we are going to keep 
the resolution a little low. If your 
resolution and size is not 10, then 
input 10 in all the six boxes. Change 
the Temperature and Fuel to Dynamic 
Grid from the dropdown menu. 

Change your boundary from Y to 
–Y. Play the animation and see how 
it looks. Select the container, and 
under the fluidEmitter1 attributes, 
change the following options:

Fluid Attributes: Heat/Voxel/Sec = 
2.000; Fuel/Voxel/Sec = 4.000

Fluid Emission Turbulence: 
Turbulence = 1.150. 

Go to the fluidShape1 attributes 
and change the following options: 

Density: Buoyancy = 9.000; 
Dissipation = 0.182

Inside the fluidShape1 attributes, 
change the following options under 
the Contents Details section:

Velocity: Swirl = 10.000
Turbulence: Strength = 0.010
Temperature: Temperature Scale = 

1.930; Buoyancy = 9.000

Dynamic Grid

Dynamics Emitter Attributes
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Select the container, and under the fluidShape1 
attributes, change the following options under 
Contents Details:

Fuel: Fuel Scale = 1.960; Reaction Speed = 0.970

Scroll down to the "Shading" section and change 
the following options:

Shading: Transparency = White Grey; Dropoff 
Shape = Sphere; Edge Dropoff = 0.440

Color: Selected color = Black

Scroll down to the “Incandescence” section, and change the graph as shown 
on the image. Play the animation and stop it in a place where you think it is 
suitable to render. Render one single frame and you’ll see the Fire that you 
have created from scratch. For more, watch the video titled Dynamics_Fire 
in this month's DVD.  
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Lighting

Lighting, if used effectively, along with UVMaps, camera angles and textures 
will add life to your scene. In fact, even when your modelling doesn’t 
meet expectations and you don’t want to waste time and miss your 
deadline, you can always use lighting so that your models and textures look 
really pleasing.

7
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Sometimes fog appears 
like an inverted cone. The 
only difference between 
people who light on sets 
of a movie, television or 
a commercial is that they 
light the scene in the real 
world using spot lights, 
bulbs, bounce, diffusions, 
reflectors and overheads, 
whereas a 3D lighting artist 
does it in a 3D world with 
3D lights and a set of attributes that are 
in one single software.

For a 3D lighting artist, being aware 
of the different lighting conditions is 
very important. To understand how the 
3D lighting works, it’s important to play 
around with the lights and get familiar 
with the term, and lighting itself. In 
Maya, if you don’t have any lights in your 
scene, it will be rendered as a complete 
black image. 

The types of lights that Maya has are 
Ambient, Directional, Point, Spot, Area and 
Volume light. 

If you don't add lights to a given 
scene, the entire scene and objects will be 
rendered as a black frame (as in Maya). In 
other programs (such as 3DS Max), there is 
default lighting in a scene that is replaced as 
soon as you start adding lights. Depending 
on how you add lights to the scene will 
determine the effect.

Lighting guidelines
• The type of lighting you would use for 

your scene would depend on things like 

RimLight separates an object from the 
background

If a colour is a hot, it should come from a hot 
source such as a candle or sun. Similarly, 
cold colours from the sky, water or snow

In a scene during the night, notice the street light, you can see dust 
fl oating in the air
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weather condition, time of the day (if it’s daylight, nightlight, dusky, dawn, 
sunny). Tip: There is always only one light source – The sun or the moon, 
unless there are lamps, streetlights, car lights, house lights involved. 

• At times when your textures are lit, it won’t give the desired effect unless 
you tweak your colours on your objects.  

• Make sure you don’t have any dark areas or places where light doesn’t 
follow. 
To fake lights in the 3D worlds, visual effects artists use terms such as Key 

Light, Fill Light and  Rim Light.

Keylight
This type of lighting creates the main lights in the scene to light up the 
model and defines its most visible part. The sun or lamps can be considered 
as key lights.

Fill light 
This is a soft light that extends the keylights horizons in real world. The sky 
can be considered as fill light.

Rim Lights 
This creates a bright portion on an object to visually separate the object from 
the background. 

Colour
Colour forms one of the most important factors in Lighting. Light is usually 
white in colour, but when white light bounces on leaves or the ground or 
even on walls, our surrounding seem to have a lot many colours. Colours 
will always be either of Red, Green and Blue. The colour temperature chart 
has a bar with colours from Red to Blue.  Let’s see the different types of lights 
in Maya.

Ambient Light 
This refers to the illumination surrounding an object or scene. We put 
ambient light in a scene to give an overall ambient feel to it. The ambient light 
adds diffuse light to the scene.

Directional Lights
Lights that travel in a parallel are called directional lights, and also travel the 
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furthest. The direction of the light is defined by the light’s orientation. These 
types of lights are parallel to us because the source is at an infinite distance 
from us. In Maya, only the direction of the light source matters and not the 
position. The best example of this light is the Sun.

Point Lights
Light coming out from a single source and going in all directions is termed 
as point light. This light fades off after a certain distance. A light bulb is a 
good example. 

Spot Light
A spotlight shoots light rays from one single point. This type of light has both 
position and direction, which you can manipulate as and when you want. 
The light fades off as the object goes further away from it. Since the spotlight 
itself is a cone, it emits light and falls on an object, with the illuminated area 
forming a cone. 

Area Light
The angles formed with the area light and the point that is shaded determine 
the illumination. As the point moves further away from the area light, the 
angle decreases and illumination decreases, much like decay.

Volume Light
Volume light is similar to a point light, only difference is you can define the 
spread by simply scaling it, also it’s a soft light that you can use in your scene 
to give a nice smooth look.

Open the animation scene and save it as CubeHouse_Lighting.ma. Take 
the Cube house on one side, just so when we put some lights in the shot, and 
enable shadows it won’t affect the rest of the objects and we will be able to see 
clearly. Put a plane under all the objects.

Locate the black button on the Status line. When you hover your mouse 
over it, it says render the current frame, which means it will render 
the frame you are on in an image format. A Renderer takes the 3D data from 
your scene and renders it out from a camera as an image file. When you hit 
that button, you’ll see your scene being converted into an image without 
lines and the grid around it. 

Except for the colour, you can manipulate the output in the render 
settings window. In the render setting, on the top of the window, there is 
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something called as Render Using Maya Software and a drop down menu 
that also includes Maya Hardware renderer. Maya has another renderer 
called Mental Ray. If it’s not there in your drop down, then go to Windows > 
Setting / Preferences > Plug-in manager and locate a file called 
Matatomr.mll. Click on Load and you’ll see the mental ray in the “Render 
Using” dropdown Menubox. Let’s make one change here before we go ahead 
with lighting.

Open the Render settings, and go to the Common tab. Scroll down to the 
bottom and open the Render option menu. Uncheck the Enable Default 
Lights button and close the window. This will take all the lights that were 
lighting the scene by default. If you render a single frame now by clicking 
on the black button, you will notice that the whole render has gone black, 
but, if you click on the white button that says Display Alpha Channel 
beside the RGB channel button, you’ll notice that the shot does have an 
alpha channel to it, but only because there is no sign of light in the scene, 
it looks black.

Now that we know what rendering is, let’s add a directional light in 
the shot. To do this, go to Create > Lights > Directional Light. 
Directional light doesn’t depend on the position or scaling, but on rotating, 
place the light in an angle you’d prefer, and render the image. You will be able 
to see some light that is hitting the object. Naturally, you won’t be able to see 
the light source. You can rotate the directional light in all 360 degrees and see 
how it’s affecting the objects. 

With the Directional light selected, go to the Attribute Editor and look 
at the first option that says Type. This is also a place where you can specify 
which light you would like to use from the drop down box. The default here 
is white, but sometimes when there is some blue light or an orange light from 
the sky. 

Next is the intensity slider. The default value is 1, but in case there is a 
stronger source of light, then it is suggested to tweak it accordingly. Decay 
Rate Specific to Spot, Area, and Point lights, this attribute determines the 
rate at which the light intensity fades (decreases) at a distance. 

The next thing we tweak is the shadows. Click on the small arrow beside 
shadows, which will open up the menu and show a bunch of attributes 
attached to it. You can click the checkbox, which says “Use Depth Map 
Shadows”. This will enable normal shadows. Hit the current render button 
and see how it looks. Shadows will appear in the render that you just did. 
If you zoom in a little bit more, you will notice that the shadows are tearing 
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slightly. This is when you go to the next option, which says Resolution. You 
can increase it to 1024 to get a smoother edge. The more you increase, the 
better your shadow is going to be. Filter size and bias are the options used 
to make the edge of the depth map shadows smoother. You can compare the 
images by saving the before and after.

Raytraced shadows produce very good results in most situations and 
the edges that look sharper in the depth map shadows will look smoother 
in raytrace. You can play with the three controls (Light Angle, Shadow rays 
and Ray depth Limit) to get the desired look for the shadow. You can select 
a region and tweak the values there to save render time. You can also delete 
the Directional light.

Let’s put an ambient light in the scene and see how it looks. To do this, 
go to Create > Lights > Ambient light. The difference between 
the attributes of the Directional light and Ambient light is that the Ambient 
light has an additional value slider called Ambient shade and it has no 
depth map shadows. In the ambient shade slider, if you change the value 
to 1, there will be light only in one direction. Similarly, if you set it at zero, 
it will come from a single source. The default value here is 0.45. The 
position of light is important.

Using the point light can be very effective in many ways, since it’s a source 
of light that glows from a single point and in 3D if you are doing interior 
lighting, and then the use of a point increases. 

The position of the light matters here. The Spot light looks like an 
inverted cone and also works like a cone. The light doesn’t penetrate 
though the cone but it surely illuminates its exterior. Similarly, a container 
called cone manipulates the light. Let’s have a look at the attributes of this 
cone, which are different from that of any other light. 

Cone Angle
This is where you can specify how big the radius of your cone is going to be. 
For example, if you have a scene in which you need to light up a character 
that is singing on the stage, you will need to put a spot light around it and 
not all over the stage. 

Penumbra Angle
You can change the smoothness of the radius and make it soft on the edges. 
Render out an image with the value 0 and 4, you will see the difference that 
it makes. 
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Dropoff
An option to change the smoothness of the light from the source itself.

Light Fog
The fog that is produced when light hits the ground. Sometimes it's also used 
as god rays. You can click on the small arrow icon beside the name, to change 
the colour of the fog. In short, you have complete control over what you are 

doing when you are lighting. This comes in handy when you are lighting up 
a scene where you have streetlights, or light coming from a window, or even 
a cars headlights.

Fog Spread and Fog Intensity are additional attributes to make the fog 
thicker, denser and smoother. 

This light has the same shadow attributes as the Directional Light. The 
position, scale and rotation is important.

The area light is a 2D rectangular light source. A large area emits more 
light, and therefore, also the distance to the objects matters. The position, 
scale and rotation are important.

Let’s start with the scene lighting now that we understand what lights are 

Your render will look a little fl at and dull
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and what type of light are suitable to light scenes. Open the CubeHouse_
Animaton.ma file and save it as CubeHouse_Lighting.ma. This way, we'll 
have a safe copy of the animation file. We need to add some sunshine to the 
scene. Start by creating a directional light outside the house and point it in 
a direction where it looks like the light is coming from the window. You can 
also do that by selecting the light, clicking on Panel in the viewport and 
selecting Look through Selected. This will enable you to look through 
the light and adjust the direction where it should shoot at. 

Once you are satisfied with the position, choose the camera viewport and 
render the current frame. Make sure that in the Render stats of the House 
mesh, “Opposite” is switched off and “double sided” is turned on. 

Open the Attribute Editor and select that directional light. Click on the 
directional LightShape1 tab and see the number of preferences to change 
the light and conditions on it. Increase the intensity to 5 and check the 
single frame render. You will see that the light has become stronger, but it 
still looks dull because it needs shadows. Expand the shadow option from 
the attributes and check the use depth map shadows. Render and see the 
difference, and you'll notice now the whole image seems black except for 
the light that is coming from the window. However, it still looks very rigid. 
This is when you need to play around with the settings and get the desired 

You can change the ground colour by clicking on the colour rectangle in the light clicking on the “picker tool” and 
selecting colour, or by simply choosing a colour from the colour wheel
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result. You can change your renderer to mental ray and see the difference as 
well. For this shot, we tested Maya and mental ray renderer and were 
satisfied with the mental image. Try switching on the raytrace shadows and 
increase the Light Angle and Shadow Rays amount to 4 and 64 respectively. 
Let the Ray Depth Limit be 1. Render out the image and see the difference 
it makes. 

Now that we have shadows and light coming from the Sun, the whole 
room still looks dark and the shot doesn’t look too pleasing to the eye. We 
need to light up the interiors as well. We are going to change the light or add 
lights according to the angle of light and its bounciness. If you think of how 
the light is travelling in this shot, you will be able to notice it comes from the 
window, hits the corner of the walls and illuminates the whole room. But the 
objects are still visible. 

Create an area light and face it towards the ground. If you render this 
frame it is going to blow white colour all over the place and over expose the 
light quite a lot. To change this behaviour, go through the light attributes, 
change the Decay Rate to Quadratic and render the frame from the camera 
view again. You can see the change now. Make sure you uncheck the Emit 
Specular checkbox, which will get rid of any extra calculations and will not 
look for any shiny materials since they don’t have any.

Since we have nothing outside the window, we can either create a polygon 

The small arrow box beside the next button will get activated when you click Create
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plane and assign a texture to it or we can create the Maya physical sun 
and sky. For this exercise, we will create the physical sun and sky since it's 
quite convenient.

With mental ray selected as your renderer, go to the indirect lighting tab. 
In the environment drop down, you will see Physical Sun and Sky, next to it 
will be a button saying Create. Click on it and you will see that the attribute 
editor showing its properties. We will change only one thing in this. Inside 
the B Unit Conversion, change the value to 0.000050. 

Render the camera view and see how it looks like. It will take some time 
to calculate since the final gathering is on. Final gathering is a technique for 
estimating global illumination for a given point by either sampling a number 
of directions in the hemisphere over that point. You can always save the final 
gather rendered image, save it and do your lighting according to it. To turn 
it off, go to Indirect Lighting and scroll down to the Final Gathering drop 
down and uncheck the Final Gathering option. Render and see the difference 
without the final gather.

Although, we still need to delete the extra sun that was created by Maya 
Physical Sun and Sky. Open your outliner and delete the sunDirection 
light from it. This is when you will be able to see your sun coming from 
the window and hitting the walls, at the same time the light bounces on the 
ceiling and it pours out a little light. 

What we did for the ceiling, needs to be done to the ground as well. 
Instead of creating a new light, we can just duplicate and rotate the ceiling 
light and adjust it in such a way that it sleeps on the ground. The lights are 
nor affecting the top and the bottom. It is advisable to pick a colour from the 
shot where the light is emitting. Always render you image to see the changes 
that you have made. The new area lights aren’t causing any shadows since 
they are just fill lights that fill up the scene.

For a bounce light, create a point light and drag it to a position where the 
sunlight is hitting the walls. Place it a little above the ground and the walls. 

Open the attribute editor while the point light is selected and change the 
Decay rate to Liner. Render and check how much it is affecting the scene. 
You will see that it’s affecting the walls and pouring unnecessary light on 
it, which we can exclude by using the Relationship Editor. You can use the 
Relationship Editor to edit relationships between objects in Maya. These 
relationships include Sets, Deformer Sets, Character Sets, Partitions, Display 
Layers, Render Layers, Render Pass Sets, Animation Layers, Dynamic 
Relationships, Light Linking (Light-centric and Object-centric), UV Linking 
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(Texture-centric, UV-centric, Paint Effects/UV, Hair/UV, and Fur/UV) and 
Hair/Fur Linking. 

To remove the House from getting affected by the point light, follow 
these steps, select the house go to the Outliner, you will scroll till you find 
a polygon highlighted, double-click it and type CubeHouse_Mesh, so you 
know which object to choose from when you are changing the relationships. 
(Tip. It is always better to name all your objects, since it becomes easier for 
you to find all your lights and objects easily. 

Go to Windows > Relationship Editors > Light Linking > 
Light Centric. The difference between Light and Object Centric is that, 
Light Centric would show you which light affects what object and Object 
centric means which particular Object is receiving light from the list of lights 
in the scene). On the left side of the editor, are the lights and on the right side 
are the objects. If you select any light, the objects will get highlighted, the 
ones that are not are not being affected by that particular light. 

Select the point light from the left side and find where the CubeHouse_
mesh is. You will find it being highlighted. Click on it to deselect it and close 
the dialog box. This way the house does not get any lights. Render and check 
the shot. Since the point light acts like a bounce light, let us add ray trace 
shadows to it. Increase the Light Radius to 4 and Shadow Rays to 1. The shot 
looks quite decent now; all that is missing is the window glow. If you notice 
in the real world, when light comes from a window the surrounding areas of 
the wall get illuminated as well. To achieve that effect, lets put an area light 
around the window that covers the whole area. This time the intensity of this 
light would be 0.2 and Decay Rate would be quadratic. We don’t need any 
shadows since it’s facing outside. 

You can now render this scene and if you think there needs to be some 
more lights or needs some colors or additional textures. Before doing a final 
render, let us first understand Layering, which is quite important in Maya 
when you are rendering for big projects. Follow Video Lighting 1, 2 
and 3 on this month's DVD.  
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Rendering or 3D Rendering is the process of producing a three – dimensional 
image which is made in a 3D software. The rendering process is very 
similar to cinematography or real lighting in TV or films where you have to 
add lights, reflectors and produce imagery of high quality and realism. 
Although in 3D, everything is created from scratch, textured, lighted and 
finally rendered, this third dimensional data can be any geometry that is 
in the scene. 

Rendering sometimes takes a lot of time depending on the computer(s) 
and processors, the scene size, the amount of geometry and props in the 
scene. Rendering an animated movie like Shrek or Wall-e can takes ages. 
Passes are used to render out different attributes of your scene separately 
in a separate image. Some of the passes are mentioned below. (Passes in lay 
man’s language means a set of image sequences rendered out part by part 
from a scene.)

8
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Beauty Pass
It is sometimes also called as diffuse pass or colour pass which is the main 
pass and has all the lighting information except for reflection, highlights and 
shadows
Highlight Pass
They are also referred to as specular pass at times. This pass shows the 
brightest parts of the image.
Refl ection Pass
This pass shows the reflections of the surrounding objects.
Shadow Pass
This pass shows the location of the shadow in the scene.
Effects Passes
These passes include all the smoke, fire, wisps, glows, lens flares etc effects.
A Depth Pass
Also called as Z-Depth stored the Z information in the file that can be used 
for putting a depth in a flat image. 

Render layers is a very powerful feature in Maya. Let's say you have 
worked on your work really well with all lighting effects, smoke effects flying 
everywhere, really nice water simulation and overall the shot is looking 
fantastic. You used all your energy and stayed up for 2-3 weeks to finish your 
shot and probably another 4-5 hours to render your scene. When the director 
comes in and looks at the shot, he compliments you on the great work, but he 
needs some changes in the smoke, water and some buildings in the centre. 

This is going to take a lot of time, energy 
and effort. Instead, if you have the objects 
in layers, all you need to do is render them 
out in separate layers. This way you will 
have complete control over them and you 
can do the minor tweaks and render that 
particular layer which will take probably 
1/10th of the time. 

This way, when the director asks you to 
make some changes, you can do that in less 
than an hour and show him a new version. 

8.1 Using layers and passes
In earlier versions of Maya, the Render 
layers and Passes were considered the 

You can fi nd the layers under the channel 
box window
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same. Now in Maya 2009, the controls have become abundant. Looking at 
your Layer panel you will notice three buttons Display, Render and Anim.

Display is used only if you want to hide some specified object temporarily, 
or lock the object just so you don’t make any changes to it by mistake. Click 
the Display button and click on the icon that has a white rectangle with a 
little yellow asterisk on it. You will find a new layer 1 has been created. You 
can open the outliner and select a bunch of objects. Right-click on layer 1 
and say Add Selected Objects. Inside the layer one the V means Visible 
in the shot. If you click that box again, you will notice that the V goes away 
and so does the object goes invisible. You 
can also double-click on the “layer 1” 
name, and rename it.

The next button is similar to the New 
layer, but has a small ball next to it is the 
“Create a new layer and assign selected 
objects to it” which means, if you have 
some objects selected and if you click this 
button; automatically a new layer will be 
created along with the selected objects 
in the layer. The first two buttons in the 
row are nothing but to order the selected 
layer up or down. 

Render Passes
Render Passes are the different things 
the Render Engine must calculate to give 
you the final image. In each 'pass' the 
engine calculates different interactions 
between objects. Using the Render Layer Editor, one can manage, create and 
delete layer, add layer overrides. You can also create a render pass from this 
render layers. Each RenderPass puts out an image or a map.

It can be either Diffuse, shadow, ambient Occlusion, or beauty Depth. 
RenderPasses that produce images can be directly viewed clicking the 
render frame icon, or, if they are in a sequence, they will be saved in a location 
on the computer; specified by the user. Unlike other versions of Maya, we do 
not have to rely on render layers to generate render Passes in Maya 2009. 
One can render out all the passes in Maya by choosing mental ray as your 
renderer. Let us now see how to set up these layers and passes. 

The associated passes are connected to the layer 
that is selected in the “Render Layer” 
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Open the render settings dialog box and clicking on the ‘Passes’ tab. The 
window is divided into two categories, Scene Passes and Associated Passes. 
Scene passes is where you need to create all your passes. The passes depend 
on what you specifically need in your shot, you don’t need to render out each 
and every single pass that exists in the menu; which will in turn take space 
on your hard drive and take a considerable amount to render. 

Hold [Ctrl] key and select Beauty, Shadow, Depth and Ambient Occlusion. 
Hit create and close. So now, we have these different passes that are available to 
us. But if we render the shot out, we will not get the passes since they are not 
associated with a particular pass. In this case, we can create the passes that we 
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just made on a per layer basis. 
Select all the passes that we 
created in the render settings 
and click the icon with down 
arrow that will get them in the 
Associated passes box.

We need to render this as a 
batch image to see the different 
passes. To do this, change your 
option in the MenuBox to 
Rendering, and go to Render 
> Batch Render. This will 
render out one single frame 
(In the render setting, we did 
not change the single frame to 
multiple frames) of each pass in 
the /CubeHouse/CubeHouse/
images folder. After rendering, 
you can open the image in 
Maya’s default fcheck and get 
the clip finalised. 
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Additional Features 

9.1 Visor
A Visor is a window or a toolbox where you can find a set of objects and 
effects. It acts like a Maya library. The only difference is that the visor has 
objects ranging from smoke elements, flesh, hair to fur. To use any of these 
tools, click on one of them and draw in one of the views, or simply click the 
middle button of the mouse and drag in the viewport.

9
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9.2 nCloth
nCloth is a fast and stable dynamic cloth 
solution that uses a system of linked 
particles to simulate a wide variety of 
dynamic polygon surfaces such as fabric 
clothing, inflating balloons, shattering 
surfaces, and deformable objects. nCloth 
is generated from modelled polygon 
meshes. You can model any type of 
polygon mesh and make it an nCloth 
object, which is ideal for achieving specific 
poses and maintaining directorial control.

In this section we shall create a flag and 
a tablecloth. For ncloth to have the correct 
behavior, it needs to interact with the 
object in a natural form. Maya converts 
a Polygon mesh into a cloth and with extra set of attributes attached, it 
becomes easier for us to add realism to it. 

Follow these steps to create an nCloth:
Open Scene ncloth_Table.ma from the DVD. We have provided you with 

Select the options you need in nCloth

Using Visor will help you with newer textures
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a simple polygon table along with a very basic polygon mesh. Select the 
checkered cloth above the table. Switch to nDynamics in your MenuBox. 

Go to nMesh > ncloth (dialog box). Click on Local Space output and 
hit Create Cloth. Extend your timeline to 100 and play the animation. You 
will notice that the cloth penetrates through the table, which is something 
you don’t want. You want it to settle on the table in a wrapped form. To 
dump the cloth on the table, select the table and go to nMesh > Create 
Passive Collider. Once you play this animation, you will see the mesh 
gets wrapped around the table like a cloth.

Change the accuracy of the cloth in the attribute editor and change the 
number of options you have. Try and move all sliders one after the other and 
check how it is affecting it. 

If you are satisfied with the cloth settling and you don’t need it to drop 
from the top, but be settled on the table from frame 1, then play the animation 
and stop at a frame where it settles down on the table. Go to nSolver > 
Initial State > Set From Current. This will get the cloth to settle 
down from the first frame itself. 

In this second part of creating the flag and pole, we will also see how to 
use point constrains to get the effect. To create a flag, open the file ncloth_
Flag.ma from the DVD. To create the cloth, go to nMesh > Create Cloth. 
Create the pole as a passive collider. Select all the vertices that are close to the 
pole by going in the vertex mode. 

Press Shift + select the pole then go to 
nConstraint > Point to Surface. You will 
now see that the points are now connected to the 
pole and if you play the animation timeline, you 
can see the flag movement. Although, we want 
only two points that need to be connected to it. 
Select the small dotted lines that connects the 
pole and the flag. 

Go to nConstraint > Select Members. 
Now select the flag and go to its vertex mode. 
Select the same points that you select to 
constrain the flag to the pole except for the 
first and last one. Then go to nConstraint > 
Remove Members. Play the animation. If you 
dislike the rigidness and want to add some more 
dynamics to it, you can select the flag and go to Your fl ag will be ready in a jiffy
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the attribute editor and change its “Life” and “Drag” values. You can also add 
more wind effect by changing the wind values. 

9.3.1 Fur 
Maya Fur is a component of Maya Unlimited that you use to create realistic, 
self-shadowing fur and short hair on multi-surface NURBS, polygonal and 
subdivision surface models. You can set fur attributes, such as colour, width, 
length, baldness, opacity, scraggle, curl, and direction globally, or map them 
on a local basis.

To add realism to fur, prepare a scene. But select areas or but select the 
whole model attach fur. Manipulate the fur attributes. If there is animation 
in the scene (a scenario where a 3D woman is running and her hair is moving 
with the wind), animate the movements and attributes. Set up a shading 
Fur effect, or you can choose from the presets that are there within Maya. 
Rendering the scene. Refining the render settings and rendering again.

Preparing the scene
Since you need to render the fur in the end, make sure your render settings 
are set-up properly. You can put fur on all surfaces: NURBS, polygons and 
subdivision surfaces. To put fur on a polygon surface, you need to set the 
UV’s correctly. Mostly, if you use a NURBS or a sub-division surface, they 
are converted to polygons to give it a better result. 

Properties of Fur
A Trimmed surface takes longer to render because of the additional maps 
and textures attached to it.

The lights in the scene are default, you need to first uncheck the default 
lights in the render settings and then you can modify the lighting in your 
scene according to the fur effects you want. For example, to get a good 
shading effect for the fur, you can add some really good Rim lights or Bounce 
lights. It's always good to reference your models, since a lot of people in 
studios work on the same shot simultaneously. 

To create fur on an object and see how it looks, import the file maya fur.ma 
from the DVD. The file contains a 3D modelled skull. Go in the face mode by 
right-clicking on the object and select the faces where you want your fur to be 
attached. You can select the faces from one of the orthographic views. Once 
done, create a cylindrical UV map by selecting polygons from the MenuBox 
(go to Create UVs > Cylindrical Mapping). 
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On the Menu bar, click on Select, and go to Convert Selection > To 
UV’s. Open the UV texture Editor. Go to Polygons > Copy UV’s to 
UV set > Copy into new UV set (small dialog box) and name the set 
as skull_fur and hit Apply and Close. Now from the MenuBox drop down, 
select Rendering and locate the FUR menu. Go to Windows > Settings / 
Preferences > Plug-in manager, scroll down and you will be able to 
see fur.mll in Windows and fur.bundle on a Mac. Load this file, refresh 
the window and close it. Go back to the object mode and select the head and 
select fur > attach fur description > New. This will attach a new 
fur description node to the skull mesh.

We need to edit the fur description nodes attributes to the desired values 
to make the hair style. You can start with a preset from the fur description 
node to make hair styles. It is the easiest way to start. 

Modifying fur attributes
You can modify fur description attributes so that all surfaces with the 
fur description attached have the new attributes. You can also style a fur 
description such as shorten or lengthen the fur on some parts of the model 
by mapping attribute values, or by painting fur attribute values directly on 

Rotate the cylindrical map to -90 degrees in the X-axis
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the model using Maya Artisan. When you apply fur attribute value maps or 
paint fur attribute values, the global fur description attributes do not change.

Animating fur attributes
You can keyframe the changes you make to fur attributes, and thus animate 
effects such as growing fur or changing fur colour.

Adding movement to fur
If you are animating your scenes, you can add movement to fur for a more 
natural effect. Using attractors, you can manually keyframe fur movement, 
or use Maya Dynamics, you can make the fur react to forces (for example, 
wind and gravity) or have fur react to the movement of the surface the fur is 
attached to (for example, a shaking dog).

Setting up shading effects
To create more realistic looking fur, you can create fur shading and shadowing 
effects. Do this by adding fur light attributes to the lights in your scene.

Rendering the scene
To see the fur effects on your models, you must render the scene. By 
default, the renderer composites the rendered fur with the rendered 
models, distributing the fur evenly across each surface (even where the 
parameterisation is uneven, for example, at the poles of a sphere).

Refi ning settings
After rendering your scene, you may have to adjust the lighting and fur 
attributes to achieve the effect you want. Re-render after making changes.

9.3.2 Hair
We create hair by the use of splines ripped off a NURBS surface, which is 
the best way to create and give it a neat style. At the same time, remembering 
that the hair system is a little tedious and can take some time to understand 
the basic functionality itself. Once the style has been set, it can be used for 
various animation purpose. 

We shall do the styling on the skull itself. First we need to define the area 
for where the hair is going to be. The best way to do that is by drawing curves. 
To create curves go to the menu-bar options. Go to create > EP Curve 
tool. Create a small curve and press [Enter]. Repeat as many times as you 



68FAST TRACK - JANUARY 2010

MayaAdditional Features9

need. Once you create the curves, select them individually in a circular form 
and loft them (you can loft by selecting Surfaces in the MenuBox and clicking 
on Surface > Loft).

After doing that, you will notice that the curves have made a surface. Let's 
go ahead in the outliner and hide all the curves. If you need to keep your 
scene clean, you can always delete them. Select the mesh in isoparms mode 
(right click on the surface and click isoparms). Select all the isoparms and go 
to EditCurves > Duplicate Surface Curves.

We're ready to assign hair to it. This method is a round about way to do it. 
If we select a curve and assign the “hair system” to it we wont get any result 
out of it because we need the hair follicle which connects only to objects. For 
that purpose we need to create a Sphere (which is our dummy object) and 
assign a new hair follicle to it. Select the Sphere, and click on dynamics from 
the MenuBox and go to Hair > Create Hair. This will add some hair 

on the sphere. Now that we have the hair follicle, we'll connect them to the 
skull’s head and see what we get.

We use this to transfer the hair system to our curves. Select all the curves 
that you previously made and go to Hair > Assign Hair System > 
hairSystemShape1. 

Creating hair is easy with Maya
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We can now delete the sphere, but to do that, go to Hair > Paint Hair 
Tool Option and change the painting mode to Delete Follicles. Now 
paint over any hair follicle you don’t need. After deleting the unnecessary 
one, delete the sphere as well.

Play the animation or render a frame and you will see the hair movement. 
If there isn’t any, then you can always add forces wind to it.

9.4 Rigging
Rigging is a method of attaching bones or 
biped to a 3D modelled character or object 
in order to make them animate. By attaching 
bones or creating bipeds, the 'character' can 
walk and make bodily movements. Joints is 
the tool that creates these bones.

Create joints by going to Skeleton > 
Joint tool. 

While creating joints, do not use the 
perspective view, but only do it via any of 
the orthographic views. Always position the 
joints inside the mesh to get better control. 
When you are done with adding joints in 
your mesh or object, hit the enter key and you 
will be done for that bone. 

While adding a bones, remember the bones are not visible when you 
render a Maya scene file. The main structure of the of the geometry should 
be ready, along with the UV mapping to avoid any bends in the mesh before 
adding the joints. A skeleton can have as many bones as you wish, till 
it solves the purpose, although it's advisable to take references and do the 
real characters accordingly.  Always research and make sure the proportions 
are correct.

Each  additional mesh or component when added should be considered 
as a separate control system, so, all joints should be created for each leg arms, 
fingers, head, ear  or tail. Referenced files are not part of the current scene. A 
path is made to point where the referenced scene file in Maya is. Referenced 
file use less amount of space and stay locked unless changed, and the update 
as and when the other artists are working on it. Try and keep the geometry 
in separate layers so that its easier to reference. Let's start with putting a 
skeleton in the 3D model that is provided to you. 

This tool enables the user to create bones 
by clicking on the grid
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Creating a bone 
To create a bone, go in the skeleton menu by choosing Animation in the 
dropdown box. In any of the Orthographic view that you click will give you 
a bones. Hit enter when you are done with it. If you click on the joint tool 
again, and click on bone that already exists, then you can start creating the 
child of that bone. A hierarchy will be formed when you create a bone from 
another bones. Always the first bone that is created is the parent and the 
rest are all children. Also, this parent can have multiple children. Bones can 
be manipulated by scaling, rotating and moving along the axis, although 
scaling is unnecessary. Although, when you move , scale or rotate the child 
bone the parent bone is not affected.

To parent an existing bone to another, select the bone (or multiple bones) 
that is going to be the child (or children), then select the bone to be the parent 
and press [P]. To unparent a bone, select the bone and press [Shift] + 
[P]. Bones are not geometry and usually are not viewed in-game (you can 
select an option in the Unreal editor to view the bones if you would like to 
troubleshoot). To name a bone, select it and go to its channel box (the right 
side with it's move, rotate, scale attributes) and select its name in the grey 
box under 'channels' (its default name should be joint#) and just type in 
a new name. 

If you do not see the channel box you can select it by going into the menu. 
Always name your bones and name them in a way that you or anyone else 
working on the scene understands, this is also very important when you are 
doing weight mapping. If an error occurs, no one would know which bone 
was affected. Do not put spaces in your bone names. You can always parent, 
unparent rename bones in the hypergraph hierarchy. You can also unparent 
a child bone (or just about anything) in the outliner by clicking the middle 
button of your mouse and dragging outside the hierarchy.

Channel Box Functions 
The channel box is where you can set exact numbers for a bones translate 
(position), rotation, scale, visibility, and other special attributes. This will 
show up on the right side of the screen when you select a bone. If it does not, 
you can access it by selecting in the menus: Display UI Elements Channel 
Box/Layer Editor. When you want to change the value of a bone’s attribute, 
just select the number field to the right of the attribute, type in the value, 
and press enter. If you don't want to alter a certain attribute of a bone or 
mesh, you can hide and/or lock certain attributes. Just select the name of the 
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attribute, right-click (and hold it) the select lock selected, hide selected, or 
lock and hide selected. 

Channel Box Quick Notes
You can select a bone’s attribute in the channel box, then in the display view, 
middle-click and hold the mouse, then move the mouse left and right to 
change the attributes. Set Driven Key is a great tool to adjust multiple bones 
without selecting every one of them. This tool is great for fingers/fists, tails, 
and other things like that. 

To create a new attribute, select Add Attribute from the Modify menu. It 
will open a window where you will give it a name (in Long Name); make the 
attribute key able, displayable, or hidden; select its data type (vector: a bunch 
of numbers; integer: whole numbers like 1, 5, 10; string: name; float: all 
numbers like 1.5, -56, 85.021; boolean and enum which you will probably 
never use); and set its numeric attribute properties minimum, maximum, 
and default value. Clicking OK will add the attribute to whichever bone/
object you currently have selected.

To access Set driven Key, go to Animate > Set Driven Key Set. This 
opens a box. The driver is an object, which when adjusted, moves the driven. 
What you will do is load up the bone that is controlling all of the movement 
into the driver, and then load the bone that is going to be moved into the 
driven. Select the first bone and click on load driver. This will make 
the bone names appear in the left box of the driver section. Then, select the 
attribute that is going to be controlling all of the movements from the right 
box of the driver section. Now select one of the bones that are going to be 
controlled by the attribute and select load driven. This should make the bone 
names appear in the left box of the driven section.

Now you are going to set the default, minimum, and maximum values of 
how the driven bones is going to be adjusted. Select the bone in the driver 
section, along with its value to control adjustment of the driven bone, set its 
adjusting value in the channel box to the default value and press key. Now 
set its adjusting value to the maximum, select the Driven bone and move it 
into the position in which you would want it at the maximum value, and 
press key. Now select the Driver bone again, set its adjusting value to the 
minimum value, select the Driven bone and move it into the position in 
which you would want it at the minimum value, and press key. Now, when 
you adjust the Driver bone’s adjusting value, you should see the Driven bone 
move accordingly.
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9.5 Human / Character Animation
Character animation is a specialised area of the animation process concerning 
the animation of one or more characters featured in an animated work. It is 
usually as one aspect of a larger production and often made to complement 
voice acting. Character animation is artistically unique from other animation 
in that it involves the creation of apparent thought and emotion in addition 
to physical action.

Open the Maya file called Stickman.mb. Mohamed Warsame has provided 
this rig on high-end 3D for all Maya users. One of the most interesting thing 
for an animator is to watch how objects, people and animals move. It makes 
so much sense to them because they can tell a lot of things just by the way 

a person walks. First off, you can quickly notice the gender, you can tell the 
audience if and how fit he/she is. Watch the video titled Character_Animation 
on this month's DVD.

Additional Resources 
Hundreds of Maya- and 3D-related resources are available on the Web. For 
general news about the animation industry, visit Animation World Network 
(www.awn.com) or Animation Nation (www.animationnation.com). You can find 

Have a look at the tutorial on the DVD titled Skeleton 1 and 2
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character animation resources and forums on CGtalk (www.cgtalk.com) and 
CGChar (www.cgchar-animation.com). Highend3D (www.highend3d.com) and 3D 
Links (www.3dlinks.com) offer tutorials and forums as well as a nice collection 
of inspirational images and videos. Other good 3D tutorial and informational 
sites include 3D Café (www.3dcafe.com) and 3D Ark (www.3dark.com). 

Off the Web, Eadweard Muybridge’s books of photos (Animals in Motion 
and The Human Figure in Motion) provide great modeling and animation 
references. The Animator’s Survival Kitby Richard Williams is a great book 
for aspiring animators to have by their side. 
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Autodesk Training 

While most of this Fast Track explores the features of Maya, this chapter 
looks at specific tasks and how to achieve these results. These last few 
tutorials are for slightly intermediate-level users. It is recommended that 
you go through the earlier chapters to properly understand the steps here. 
These tutorials were provided to us by Autodesk. Although the tutorials are 
written for Maya 2009, you should have little trouble following the steps in 
the latest version 2010.
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10.1 Basic Training
Maya Particles: Fountain
This is a simple workflow to create a fountain. This is pretty elementary and 
meant for relative new users of Maya dynamics.
Create an particle emitter set this emitter to be directional,
and the particle type to be multi streak.

Play a bit (so that particles are emitted). Select the particles and add gravity.
Note the particles will not more up on the Y axis as the gravity will pull these 
down.

Hence we have to pull up the speed.
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We now should have an effect that looks like this…

But you'll notice that the particles are going on and on way past the base 
(where the emitter position is)

Based on your need, edit the lifetime to be the number of second you really 
want to see the particles…
Changing the Lifespan Made from Live forever to Constant. This will 

then make use of the value.

Set at Lifespan. This value is set in seconds. In this example, we've set the 
lifespan to 2.



77 FAST TRACK- JANUARY 2010

Maya Tutorials 10

Notice here all the particles die of at one particular point. This is so because 
each and every particle lives the same amount of time. To get a better look it 
is always advisable to have particles die at their own individual times. Hence 
set the particle type to lifespan PP.

By default, lifespan PP (lifespan per particle) is live forever and hence we 
have to add changes inside attribute editor.

Right-click on the box at the side of LifespanPP and select runtime expression 
before dynamics.
This opens the expression editor...

Just to be sure and cross check, we set the value of lifespanPP to 2.
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When simulated, this should look identical to the earlier simulation.
So what do we want to do different?
Well, we want that particles to die in around 2 seconds. That is to say, the 
particles should pick a random value of life between 2 and 3 seconds.

This will take care that the simulation look does not die off at one time and 
will also help in the visual look of the particles. This exercise is mainly aimed 
at the look of the simulation…
Now that we have edited the end of the fountain, let's move to the look of the 
top of the fountain – this seems too constant. The more nicer look would be 
a bubbly movement.

Changing the random value gives just enough movement on the top of the 
fountain that is needed. In this case, we have added a bit of the speed to 
compensate.
Now we have something that is neat, probably not the best, but neat.
But, what if we have to do a series of fountains?
What if we needed to create 10 such fountains?
Well we are happy with the particles look, so we do not need any particles 
from any other emitter. Hence create the required number of emitters 
(creating emitter automatically creates particle objects.)
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EXCEPT for particle1 delete all the other particle objects

Then open relationship editor > dynamic relations
Select the particle object, we notice here that the particle1 is only connected 
of emitter1
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Connect this particle object to all the emitters. You should now see particles 
emitting from all the emitters. Though they may not look like the fountain of 
the first emitter. The reason is simple – the emitter values are not the same 
as emitter1.

If the values of all the emitters are the same. The image above is what one 
should get.
If the look is different, check type (omni/directional), spread, number of 
particles, direction X & Y.
First of all, let us get the overlook to be nice. Remember the particles are 
multi-sprite, hence hardware particles.
Select the particles and go to the attribute editor
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Click on the Color button. This will bring up a window asking how the 
colour is to be applied.

We need the colour to be applied per particle.

Right-click on the RGB PP column and add Ramp. Do the same again, and 
edit ramp.



82FAST TRACK - JANUARY 2010

MayaTutorials10

Edit the ramp to look like the above, basically a bright-blue to blue ramp.
That should give a relative good looking fountain/s.
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10.2 Camera mapping
Both in the past as well as present there has often been queries of how to do 
camera mapping. The idea of this type of mapping is to take the texture from 
projection through a camera rather that local mapping.
This is often need for VFX shots. Shots like the object seeming to come out of 
backgrounds and more often for effects like talking animals etc…
We are going to use much simpler objects to show this example.

Create a camera or use the persp camera and create an image plane
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And put in an image

Shade the object with a surface shader as we do not want it to get any 
highlights or shading. We projection map 

the color with an image
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The same image as that of our image plane and render this

We can notice the background sort of distorted, as the mapping on the object 
does not match the image in that of the camera plane.
Now we need to tell the object has to get not the planer mapping but mapping 
from the camera. Selct the projection mapping from the hypergraph menu
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Change the projection type

Screen clipping taken: 7/1/2009, 4:52 PM

From Planar to Perspective…

This will then allow us to edit the Camera Projection Attributes what we 
need is to change the Link to camera and specify from which camera the 
projection has to take place.
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Once this is done, more often we'd want to bake the texture on to the object.
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We can then animate the object to come out of the screen or morph to another 
shape

In the similar way we can make some nice effects … For example
From a Grumpy toad

To a Toad with a bit of smile

On similar process we can create various expressions as well as talking 
animals/objects.
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10.3 Styling with Shading network
Create a Simple scene :
Assign a shader with gird texture

What style we want to achieve this is :
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Note here that on changing the orientation of the light the shading changes
Another thing to notice is that the lines are not uniform in thickness, it's 

thickness fades towards the specular area.

Hence the "curvature" of the surface has to be kept in mind.
Take simple shader to get the "shading" hence curvature of the object.
Connect the Output color to a reverse node input.
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The outputX and outputYof reverse gets connected to grid.uwidth and grid.
vwidth

In the Graph above the output color of the blinn is also connected to grid.
lineColor.

This should deliver a crosshatch look

While we can adjust the gird lines and get either more (or Less) horizontal 
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(or Vertical) line.

We prefer a surface luminance node to be connected to the Grid.uCord of the 

Gird Node to give the horizontal lines

And if we want vertical lines, instead of horizontal lines.
Connect the luminance (surface Luminance) to the vCord (Grid). 
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Mental Ray: Geometry Shader
One of the most time consumig aspects of a Computer Graphics pipeline is 
lighting and rendering. We often have very huge scenes and geometry that 
can run into thousands and lakhs of polygons. This of course then takes a 
fair bit of time to render and evaluate.

Even a simple scene file like this, which is just a sphere with extrusions 
took 42 seconds to render. But if we have to do various changes to the lights 
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and evaluate the same, this will then take a fair bit of time. Very often making 

us wonder if we can just replace the geometry with some simple objects, 
make requisite changes in lighting and then, reput the final high res Go to 
the transform node in the Attribute editor, Geometry.

Go to the transform node in the Attribute editor,
Enable the Geometry shader
Select which Mental Ray geometry shape matches closely to the scene 

geometry.
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The scene geometry gets replaced with a simple Mental Ray primitive and 
renders in a fraction of time.
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But the look of the geometry in the viewport remains the same
This is a simple but intutive way of using geometry shaders. Note here 

that this is not the only usage of geometry shaders, the more advanced uses 

will be discussed in a later topic. 
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